Installing Skype on Fedora 16 64bit

Fedora 16 was released on 8th of November. After it was released, i downloaded the 64bit KDE spin iso and install it into my laptop immediately. All went well during the process of installation and configuration. The system is fast and it boots super fast thanks to the systemd.

I ran into problem when i try to install Skype for Fedora 16 64bit. I found out that there is not 64bit rpm available for download on Skype’s site. I thought that it is a noarch rpm hence i downloaded it and install it. When lauch it for the first time, i get an error message stating that my ld.so is not found. After searching on the internet, i found that i need to install i686 (32bit) libraries to fulfill Skype’s dependencies. Here’s the step-by-step guide on how to do it:

  1. First, download the RPM for Fedora on Skype website.
  2. Launch the terminal and type the following command to install the required libraries:
  3. 
    sudo yum -y install libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686 pulseaudio-libs.i686 pulseaudio-libs-glib2.i686 alsa-plugins-pulseaudio.i686
    
    
  4. Install the Skype RPM.

It’s done!! Just as easy as it looks

56 thoughts on “Installing Skype on Fedora 16 64bit

  1. Pingback: Skype sur Fedora 16 64bits | FlecheInThePeche.fr

  2. That works on my Fedora 16 64 bit system.

    Thanks! One would think that Skype’s RPM file would have that dependency information built in…

  3. Glad I found this — saved what would’ve been a morning of hair pulling!

    I’m finding Fedora issues much more reasonable than Ubuntu (touch wood) but perhaps that’s just cause I’m used to the quirks of *nix systems now…

    • do this and worked for me

      yum install alsa-lib.i686 dbus-libs.i686 e2fsprogs-libs.i686 expat.i686 fontconfig.i686 freetype.i686 glib2.i686 glibc.i686 keyutils-libs.i686 krb5-libs.i686 libcap.i686 libgcc.i686 libICE.i686 libpng.i686 libselinux.i686 libSM.i686 libstdc++.i686 libX11.i686 libXau.i686 libxcb.i686 libXcursor.i686 libXdmcp.i686 libXext.i686 libXfixes.i686 libXi.i686 libXinerama.i686 libXrandr.i686 libXrender.i686 libXScrnSaver.i686 libXv.i686 openssl.i686 qt.i686 qt-x11.i686 zlib.i686

  4. Pingback: [SOLVED] Weird Error for Skype Fedora 16

  5. When I tried to install 32 bit LibX I got the following error:
    Error: Protected multilib versions: 1:qt-4.8.0-7.fc16.i686 != 1:qt-4.8.0-0.23.rc1.fc16.x86_64
    Error: Protected multilib versions: 1:qt-x11-4.8.0-7.fc16.i686 != 1:qt-x11-4.8.0-0.23.rc1.fc16.x86_64

    Can anybody help how to rectify.
    thanks.

  6. I got the error:

    Error: Protected multilib versions: 1:qt-x11-4.8.0-7.fc16.i686 != 1:qt-x11-4.8.0-0.23.rc1.fc16.x86_64
    Error: Protected multilib versions: 1:qt-4.8.0-7.fc16.i686 != 1:qt-4.8.0-0.23.rc1.fc16.x86_64

    who can help me?

  7. Error: Protected multilib versions: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686 != alsa-plugins-pulseaudio-1.0.24-2.fc15.x86_64

  8. Thank you soo much i installed the rpm b4 and it wouldn’t run and these extra packages worked and now i can run skype! thanks so much

  9. Pingback: mesa-dri

  10. hey after i run command “yum localinstall skype-2.2.0.35-2.x86_64.rpm”
    i got the message
    “cannot open:skype-2.2.0.35-2.x86_64.rpm.skipping”
    please can any one help me.

  11. Tips from me – Fedora 17 x86_64: yum install gtk2-engines-2.20.2-4.fc17.i686 – adding engine to clearlooks theme.

    And skype is much nicer.

    Best regards

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre lang="" line="" escaped="" cssfile="">

Follow me on Google+

Meta